While the AWS outage and degraded performance continue, NotificationAPI services have remained stable and fully operational since early morning.
In total, our US region outage lasted approximately 2 hours and 25 minutes, from 2:53 AM to 5:18 AM Eastern (6:53 AM to 9:18 AM UTC).
We are now concluding this incident and will continue monitoring AWS recovery closely to ensure full stability.
Posted Oct 20, 2025 - 18:25 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 12:45 UTC
Monitoring
We’re experiencing an outage in our US region due to a broader AWS service disruption in the us-east-1 region. As a result, some requests and notifications in this region may fail or be delayed.
Our team is monitoring the AWS incident closely and will restore full service as soon as their systems recover. Other regions (e.g., Canada, EU) remain fully operational.
We are currently working with our enterprise clients to identify and resend missed notifications.
Posted Oct 20, 2025 - 08:00 UTC
This incident affected: APIs/SDKs, Web Dashboard, Email, SMS, In-App, Call, Browser Push, and Mobile Push.